Project

General

Profile

Bug #7936

ESA Student Profiles not working

Added by Paul Hebert over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
-
Target version:
Start date:
2017-04-10
Due date:
% Done:

0%

Estimated time:

Description

The ESA site (gcenglish.commons.gc.cuny.edu) student and alumni profiles are not displaying; attempting to navigate to them results in a 404 error.

The site runs a child theme that gives the profiles unique post types. The post types "Student Profile" and "Alumni Profile" are correctly displayed on a category page (ex. https://gcenglish.commons.gc.cuny.edu/students-alumni/student-profiles/ ) So the information all still seems to be there.

However, when you click on a profile to view a custom profile page, the 404 error appears (ex. https://gcenglish.commons.gc.cuny.edu/profile/akant-sara/ )

I can edit profiles from the Dashboard. So again, they're not gone, just not displaying.

Any ideas?

History

#1 Updated by Boone Gorges over 4 years ago

  • Assignee set to Raymond Hoh

Previously: #4033

I have spent a few minutes and haven't found any obvious culprits. When WP parses the request, the 'profile' rewrite rules are not properly registered. But I can't reproduce the problem on a local version of the site, running the same plugins and theme. I thought maybe a plugin was flushing rules on each pageload and wiping them out after the 'profile' post type was registered, but didn't find anything there either.

Ray, I'm swamped today - could you find a few minutes to have a look? It's likely that I'm missing something obviousy.

#2 Updated by Raymond Hoh over 4 years ago

  • Status changed from New to Reporter Feedback
  • Assignee changed from Raymond Hoh to Paul Hebert

The profiles appear to work for me. I clicked on a few profiles that are on the Students & Alumni page and they loaded fine.

#3 Updated by Boone Gorges over 4 years ago

Whoa - I swear this was not working earlier. https://gcenglish.commons.gc.cuny.edu/profile/akant-sara/ definitely 404ed.

It could be that when I soft-refreshed the rewrite rules, I didn't properly clear the Memcached cache.

#4 Updated by Boone Gorges over 4 years ago

  • Target version set to Not tracked

#5 Updated by Paul Hebert over 4 years ago

Seems to be working now. Who knows?

#6 Updated by Boone Gorges over 4 years ago

  • Status changed from Reporter Feedback to Resolved

Thanks for confirming, Paul. Let's reopen if it happens again.

Also available in: Atom PDF