Project

General

Profile

Bug #8534

Commons Reply To Name

Added by Luke Waltzer over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
-
Target version:
Start date:
2017-08-15
Due date:
% Done:

0%

Estimated time:

Description

Noticed that the reply to name on a post notification (which surfaced this issue https://redmine.gc.cuny.edu/issues/8183) is Hung Dam Quoc, which was the name of the student at City who registered an account using their Help Desk (https://cunycommons.zendesk.com/agent/tickets/1239).

History

#1 Updated by Boone Gorges over 1 year ago

  • Status changed from New to Assigned
  • Assignee set to Raymond Hoh
  • Priority name changed from Normal to High

Ray, can you see what's causing this please?

#2 Updated by Raymond Hoh over 1 year ago

Is the problem that the name "Hung Dam Quoc" is shown in the "Reply-To" email header?

If so, the problem is related to a change made to switch the default "Reply-To" email address to support@cunycommons.zendesk.com:
https://github.com/cuny-academic-commons/cac/commit/66519f9990de895a3d3450f4124a41f10e6913d2
https://redmine.gc.cuny.edu/issues/8225#note-11

That email address is registered to Hung's account and BuddyPress defaults to using the name of the user associated with that account.

My recommendation would be to change Hung's email address in WordPress to something else like one of our GMail addresses with an address tag (eg. OURCUNYADDRESS+hung.dam.quoc@gmail.com)

#3 Updated by Boone Gorges over 1 year ago

Resetting the user's email address seems correct to me in any case, since that user doesn't have access to the Zendesk account. I've just changed it to .

The account's email address was changed in https://redmine.gc.cuny.edu/issues/7923#note-19.

Ray, can you verify that this fixes the issue?

#4 Updated by Raymond Hoh over 1 year ago

Hi Boone,

Just checked and the email address associated with hungdamquoc is still the Zendesk email address.

Do you want me to change it to the Gmail address?

#5 Updated by Boone Gorges over 1 year ago

Hm... I changed it at the CLI, where it's reflecting the new address. I see now that it's not showing as changed in the Network Admin. But if I try to change it there, it doesn't stick.

If you have a minute to take a look at why it's not working, that'd be great. Otherwise I'll look myself tomorrow.

#6 Updated by Raymond Hoh over 1 year ago

  • Status changed from Assigned to Resolved
  • Target version set to 1.11.10

It's a bug or conflict between wp-cli and our Memcached object cache.

I ran clean_user_cache( USER_ID ) in a /mu-plugins/ file and it worked after that. Do we want to debug this some more?

Going to mark as resolved in the meantime though as the main issue is now fixed.

#7 Updated by Boone Gorges over 1 year ago

I ran clean_user_cache( USER_ID ) in a /mu-plugins/ file and it worked after that. Do we want to debug this some more?

Ah, I was going to go down this route, but I ran out of time. This doesn't sound fun to debug, so I'd say skip it for now. Thanks for following up!

Also available in: Atom PDF