Project

General

Profile

Bug #8659

Help email us link not working

Added by Matt Gold over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Help/Codex
Target version:
Start date:
2017-09-01
Due date:
% Done:

0%

Estimated time:

Description

Today on a desktop mac, inChrome, I was showing someone the Commons and tried to show how to ask for help by clicking the email link in the top mac help drop-down. Clicking the link did not open a modal to allow users to contact he CAC as it should have.

I have not had a chance to test on another computer and I recently installed a few ad-block/provacy browser extensions that could have been at fault, but I wanted to note what I saw.

--

Side note: I'm accessing Redmine from my phone and it seems newly-mobile friendly (though maybe that was done earlier and I am just forgetting)

export.pdf (14.4 KB) export.pdf Matt Gold, 2017-10-11 11:29 AM

History

#1 Updated by Boone Gorges over 4 years ago

  • Assignee changed from Boone Gorges to Raymond Hoh
  • Target version set to 1.11.12

It looks like assets from zendesk.com are either being blocked in some cases, or are slow to load. I've been testing on a handful of computers, and on Mac/Chrome https://assets.zendesk.com/embeddable_framework/main.js is timing out when loaded from the Commons. When loaded in its own tab, it's taking close to 10 seconds to load.

Ray, are you able to reproduce? Is it possible we're being rate-limited by Zendesk or something?

As a mitigation, a couple things to consider:
- Is it possible and/or wise to host a copy of Zendesk's script locally?
- Can we rewrite the JS so that the mailto link opens when the external script can't be loaded?

#2 Updated by Raymond Hoh over 4 years ago

I'm unable to test on a Mac, but main.js on Windows 10, Chrome 62 loads at around 250 - 330ms over here from the Commons homepage, which is pretty fast.

However, loading main.js in a separate tab took close to 6 seconds over here, which is quite long.

Matt, were you on a wifi connection?

It might have been a hiccup with Zendesk's server sending the JS request.

For now, I have implemented Boone's second point in https://github.com/cuny-academic-commons/cac/commit/e3aa1a3fe9537e9c25bcdd868164134eb4b3853c. This is live on production.

While looking into this issue, I found that other people had similar concerns about Zendesk's JS being too large and affecting load time:
https://support.zendesk.com/hc/en-us/community/posts/206495757-Slow-Widget

At the end of that thread, a developer coded an alternative Zendesk widget with PHP and jQuery that is lighter than Zendesk's default widget:
https://github.com/mauricekindermann/z_widget

If we went this route, we would probably need to add anti-spam measures to this custom Zendesk form.

#3 Updated by Boone Gorges over 4 years ago

Ha, the response from Zendesk on that thread to all the complaints about library size is pretty much "too bad".

It'd be helpful to know whether this problem is really widespread. If it's only something that happens occasionally, due to high traffic or something, then maybe we can just live with it.

#4 Updated by Matt Gold over 4 years ago

Just as a point of information, any email to results in the creation of a ticket, though with less info than the Zendesk widget supplies (like the page the user was on when the help button was clicked), so as a last resort, we could design our own email form if this problem becomes more widespread.

In the meantime, I'll keep testing the button from my Mac/Chrome set-up to see if it persists

#5 Updated by Matt Gold over 4 years ago

for me, now, it is opening up just as a mailto link, which I guess means that the ZenDesk script is timing out?

#6 Updated by Boone Gorges over 4 years ago

Probably. Can you open the Network tab of your browser's developer tools, type 'zendesk' into the Filter dialog, and do a hard refresh of the page?

#7 Updated by Raymond Hoh over 4 years ago

Matt Gold wrote:

for me, now, it is opening up just as a mailto link, which I guess means that the ZenDesk script is timing out?

Either that, or your Chrome set up is blocking the Zendesk JS from downloading. You said you installed some adblocking addons on Chrome. It's entirely possible that those requests are being blocked if you disabled 3rd-party assets from downloading.

Can you try Firefox on Mac and see if you are able to duplicate?

#8 Updated by Boone Gorges over 4 years ago

  • Target version changed from 1.11.12 to 1.11.13

#9 Updated by Boone Gorges over 4 years ago

  • Target version changed from 1.11.13 to 1.11.14

#10 Updated by Boone Gorges over 4 years ago

  • Target version changed from 1.11.14 to 1.11.15

#11 Updated by Boone Gorges over 4 years ago

Matt, would you mind checking to see whether this is still happening for you? If it was due to temporary network-related issues, we can probably close out the ticket. (I've just verified that it's working for me, outside of the GC.)

#12 Updated by Matt Gold over 4 years ago

Okay -- so, here is my report, all on a Mac:

Chrome: when I click "send us a message," I get the mailto link, which I think means the script is timing out

Firefox: when I click "send us a message," the modal interface to send a message appears as expected

Safari: when I click "send us a message," the modal interface to send a message appears as expected

FYI, I've attached a PDF with system details in case that helps. All of these tries are from within the GC

#13 Updated by Boone Gorges over 4 years ago

Hm. I'm also experiencing the problem on Mac/Chrome, but only there - all other combinations of browsers and OS seem to work OK.

In my case, it looks like the Privacy Badger extension is the culprit. If I disable it, or whitelist assets.zendesk.com, everything works fine.

Matt, can you confirm whether you're using a similar privacy extension, and whether disabling it fixes the problem?

There are limits to what we can do with browsers that intentionally block scripts like this. There are legitimate privacy concerns with the loading of third-party JS.

#14 Updated by Boone Gorges over 4 years ago

  • Target version changed from 1.11.15 to 1.11.16

#15 Updated by Matt Gold over 4 years ago

Yup -- that's exactly it, Boone. I am using Privacy Badger with Chrome. I think I am likely an edge case and that a straight mailto link is an acceptable alternative. If you agree, let's close this ticket. Sorry for the bother!

#16 Updated by Boone Gorges over 4 years ago

  • Status changed from Assigned to Resolved

Not a bother! I'm glad we figured it out. I'll close the ticket, but Ray, please chime in if you think there's anything we can do to appear friendlier to Privacy Badger and the like.

#17 Updated by Raymond Hoh over 4 years ago

If you are using adblocking and privacy-related addons, it is expected that you know what you are doing though.

With that being said, we could do one of the following:
- Host Zendesk's JS ourselves as mentioned in the first comment. Potential problems are that we are out-of-sync with Zendesk's JS API if they ever change anything.
- Create our own Zendesk contact form as mentioned in the second comment. Implementing this would especially lighten the JS load, but would take a tiny bit of dev time. If this is a priority, I can work on this.

#18 Updated by Boone Gorges over 4 years ago

Since this is a problem only for tinfoil-hat types, let's not do anything for now. If we get complaints in the future (especially about performance, which wasn't the issue here but is definitely a general problem with the widget) we can circle back.

#19 Updated by Matt Gold over 4 years ago

Boone Gorges wrote:

Since this is a problem only for tinfoil-hat types, let's not do anything for now. If we get complaints in the future (especially about performance, which wasn't the issue here but is definitely a general problem with the widget) we can circle back.

I have decided to take this as a compliment ;)

Also available in: Atom PDF