Project

General

Profile

Bug #9977

ACERT website down

Added by Matt Gold over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority name:
High
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2018-07-02
Due date:
% Done:

0%

Estimated time:

Description

From Zendesk:

Good morning,

Our website, acert.hunter.cuny.edu, is down. I am unable to even access the Wordpress CMS. I've attached a screenshot. Please help!

Screen Shot 2018-07-02 at 10.48.06 AM.png (38.1 KB) Screen Shot 2018-07-02 at 10.48.06 AM.png Matt Gold, 2018-07-02 02:37 PM
doc.pdf (2.45 KB) doc.pdf Matt Gold, 2018-07-03 12:32 PM

History

#1 Updated by Boone Gorges over 3 years ago

  • Category name changed from Domain Mapping to WordPress Plugins
  • Target version set to 1.13.5

The plugins-list plugin introduced a spaceship operator into its late-June update. This operator is supported only on PHP 7+. I have removed it in a hotfix, but have not yet committed the fix.

I guess we need to fix the plugin and then blacklist it from being updated until after we update PHP. I don't have the time to figure this out at the moment, so I'm leaving the ticket open.

In the meantime, the site is up.

#2 Updated by Matt Gold over 3 years ago

Great -- thanks so much for the quick work, Boone!

#3 Updated by Matt Gold over 3 years ago

Hi Boone -- we just had another report that the ACERT website is still down. Can you please look into this?

#4 Updated by Boone Gorges over 3 years ago

The following URLs are loading for me:
http://acert.hunter.cuny.edu/
https://acert.commons.gc.cuny.edu/

There is a bit of redirect magic happening due to domain mapping, so I'm CCing Ray here.

I'd suggest that the user try a different browser, or try clearing the browser cache. (Firefox in particular can be weird about caching redirects.) If the problem persist, please provide more details:
- what is the URL being requested?
- what URL shows in the location bar?
- what error do you get in the browser? ("too many redirects", or something like that)
- are you logged in? if so, what is the user account?
- OS/browser info

#5 Updated by Matt Gold over 3 years ago

Thanks, Boone. FYI, those URLs are loading but it just took about 30 seconds for them to resolve for me. My setup is attached and I will add the user's info when I have it.

#6 Updated by Boone Gorges over 3 years ago

I'm not seeing the 30 second load time on my end, but again, this might be explained by sticky browser caches. Ray, would you mind having a quick look to see if you're able to reproduce? If not, we can wait for more info from users.

#7 Updated by Matt Gold over 3 years ago

  • Status changed from New to Rejected

the user reports that the site is working again.

Also available in: Atom PDF