Project

General

Profile

Bug #12183

User cannot access their sites

Added by Laurie Hurson about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
-
Target version:
Start date:
2019-12-04
Due date:
% Done:

0%

Estimated time:

Description

Hi All,

I think this might be related to the issue discussed on the dev call yesterday and mentioned in the ticket #12165. I had some trouble following the specifics but I think I understood that its related to the deletion of users from sites or the wiping of the user roles on a site?

In this case, a Commons user is trying to access a site on which he is an admin. He can view the site in My Sites but when he clicks he is re-directed to the Commons page.

His user name is "fcanela" and the site he is trying to access is https://fcpd.commons.gc.cuny.edu/

That's all the info I have right now but Let me know if I need to follow up with him about anything else


Related issues

Has duplicate CUNY Academic Commons - Bug #12184: loss of administrative rightsDuplicate2019-12-04

History

#1 Updated by Laurie Hurson about 2 years ago

Not sure if this is how we should be reporting these but another user just emailed reporting the same issue:

User: Van Bich Tran
Site: https://lagccnsdoer.commons.gc.cuny.edu/

#2 Updated by Boone Gorges about 2 years ago

  • Has duplicate Bug #12184: loss of administrative rights added

#3 Updated by Boone Gorges about 2 years ago

Looking into it.

#4 Updated by Boone Gorges about 2 years ago

Adding Ray as a watcher. At a glance, I don't see evidence that this is related to #12180 and yesterday's incident, and I wonder whether it might be due to something related to the new private-site infrastructure in 1.16. I'm continuing to investigate.

#6 Updated by Boone Gorges about 2 years ago

  • Status changed from New to Reporter Feedback
  • Assignee set to Boone Gorges
  • Target version set to 1.16.1

This was caused by a missing restore_current_blog() after a switch_to_blog(), introduced as part of the 1.16 release. Fixed in https://github.com/cuny-academic-commons/cac/commit/00c12cbf5856417b939ecf765225f918d83f3a69. In addition, the function in question should not have been called at all in most contexts; this has been fixed in https://github.com/cuny-academic-commons/cac/commit/0efd793224ef0d61a9b139a3193f03e973ce0284

These changes have been deployed to production. Could I get someone to confirm please?

#7 Updated by Laurie Hurson about 2 years ago

Ho Boone,

Sorry for the delay. These faculty have confirmed that this issue is resolved.

#8 Updated by Boone Gorges about 2 years ago

  • Status changed from Reporter Feedback to Resolved

Thanks for confirming!

Also available in: Atom PDF