Project

General

Profile

Bug #13341

Forum reply problems

Added by Marilyn Weber about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Group Forums
Target version:
Start date:
2020-09-17
Due date:
% Done:

0%

Estimated time:

Description

User Steven Kidder reports:
Hi, I am new to this and trying to have my class post on a topic, either an original response or a comment on each other's responses. Sometimes they line up in chronologic order (not what i want), and sometimes they are indented and differently-ordered so that it's clear students whether or not students are making a response to an earlier post. I can't see any option for how to choose one option versus the other. See the two versions below. What do I do? thanks.

Later he elaborated:
I tried using the “quote” button, but then it makes a new post in chronologic order (down at the bottom) for each reply. For 40 students and multiple intermixed replies it’s totally a mess this way.

https://commons.gc.cuny.edu/groups/eas-217-f20/forum/topic/global-impacts-video/

Maybe you will see how my “quote” post at the bottom is not where it “should” be, i.e. next to the original post by Josue.

Screen Shot 2020-09-15 at 12.58.50 PM(1).png (288 KB) Screen Shot 2020-09-15 at 12.58.50 PM(1).png Marilyn Weber, 2020-09-17 12:41 PM
Screen Shot 2020-09-15 at 1.02.31 PM(1).png (243 KB) Screen Shot 2020-09-15 at 1.02.31 PM(1).png Marilyn Weber, 2020-09-17 12:41 PM
Screen Shot 2020-09-17 at 1.13.18 PM.png (885 KB) Screen Shot 2020-09-17 at 1.13.18 PM.png Laurie Hurson, 2020-09-17 02:55 PM
correct- threaded.png (964 KB) correct- threaded.png Laurie Hurson, 2020-09-17 02:55 PM
Screen Shot 2020-09-17 at 1.13.24 PM.png (862 KB) Screen Shot 2020-09-17 at 1.13.24 PM.png Laurie Hurson, 2020-09-17 02:55 PM
incorrect not threaded.png (815 KB) incorrect not threaded.png Laurie Hurson, 2020-09-17 02:55 PM
Recording #3.mp4 (14.4 MB) Recording #3.mp4 Laurie Hurson, 2020-09-17 03:24 PM

Related issues

Related to CUNY Academic Commons - Bug #13346: Update cache drop-in to support wp_cache_get_multiple()Resolved2020-09-18

History

#1 Updated by Marilyn Weber about 1 year ago

Please add Laurie as a watcher on this ticket.

I asked for her help, and she replied:

Hi Steve and Marilyn,

Could the different views be a function of whether or not you are viewing the group as signed in (or not) to the Commons?

When I am signed in, I can see the posts and nested comments as desired (i.e. they are not chronological). But when I view the same URL and I am not signed in, I see posts in chronological order. Steve, will you test this to see if you experience this too? This might not be it but I thought it was worth mentioning. I couldn't determine log in status from from the screenshots.

I think you all have already clarified this but I wanted to add that the "quote" button does not nest the comment under another post but instead adds the response to the end of the chronological feed with a call out of the quoted post. This is not the button you want students to use to reply. If students are trying to make a nested comment (i.e. a comment replying to another post), they will need to his "reply" on the post to which they would like to respond. Upon clicking reply, they will be brought to the writing field at the bottom of the page to submit their reply. So, students need to use the "reply" function in order to create a nested comment (a reply to another post) that appear out of chronological order.

Let me know if the signed in/out view might be the issue here. If not I can start a ticket with the developers.

Thanks,

Laurie

#2 Updated by Marilyn Weber about 1 year ago

I replied:

Laurie -

Even when I'm logged in, the replies from Steve are all at the end. See here - https://commons.gc.cuny.edu/groups/eas-217-f20/forum/topic/global-impacts-video/page/3/

- Marilyn

#3 Updated by Marilyn Weber about 1 year ago

Perhaps I spoke too soon! He just wrote "Just to update, today, when I went to use the site, it worked OK. There is one post that seemed to not work for me to reply to (triggered a bunch of errors, and I can probably document that with a video if it would be helpful). But the main problem that inspired my email to the help desk doesn’t seem to be happening at the moment.

So I no longer need help, it seems. But if you want to work on fixing bugs and so forth, please send me your full email addresses and I’ll try to put you on as admins and/or provide better documentation of the error(s).

FYI I am using Safari browser on a MacOS Mojave, but it also happened when I switched to Firefox"

#4 Updated by Boone Gorges about 1 year ago

  • Assignee set to Raymond Hoh

Logged-in users have the ability to set whether they'd like the reverse-chronological view, or the threaded view. See #3192 and My Settings > Forums.

Ray, given the above, maybe you could say something about whether the user is seeing unexpected behavior? Or perhaps we should rethink the defaults?

#5 Updated by Laurie Hurson about 1 year ago

Hi all,

sorry to be late on this, I was writing a ticket before i got pulled into calls. I am confused about this too.

A professor has been having issues with forum threads not threading correctly.

From what i see, sometimes the forum threads correctly and replies appear under the post it is related to, sometimes it does not, screenshots attached. I thought it might be the URL but the url is the same in both instances.

#6 Updated by Boone Gorges about 1 year ago

Laurie - See my comment at https://redmine.gc.cuny.edu/issues/13341#note-4. This is a user setting at My Settings > Forums. I think we could discuss whether and how the defaults should work; and we might consider some additional UI to make it clearer whether you've enabled threading (or even a quick link to toggle on a per-thread basis - didn't we once have this?), but the basic answer to the discrepancy in your screenshots is that different users have different settings.

#7 Updated by Laurie Hurson about 1 year ago

Ah, sorry for the confusion and for having missed the settings info.

I am think i am still confused because A) my forum settings are set to "threaded" and B) all of those screenshots were taken by me and sometimes I see the threaded view and sometimes I do not. I added a video of me clicking the link several times resulting in two different views.

Sorry if this isn't a bug or I am just confused but i did want to share because I think this is may have what caused the professors confusion in the first place.

Either way, I do think a conversation around defaults and UI for forum settings would be useful at some point.

#8 Updated by Raymond Hoh about 1 year ago

I'm looking into it. Perhaps it has something to do with bbPress 2.6 because we never received these reports for bbPress 2.5.

#9 Updated by Raymond Hoh about 1 year ago

There are two differing issues being reported here:

1. The "Quote" button doesn't use the reply ID. I can confirm that this is a bug.
2. The user forum display setting doesn't seem to stick. Not sure what is happening here. My guess is that this might be a result of caching, but I'm still looking into this.

#10 Updated by Raymond Hoh about 1 year ago

The default display option on the forums is threaded for logged-in users. If you are logged out, it reverts to linear oldest. As reported, the issue is the threaded display option wasn't persisting on certain page loads and can sometimes revert to linear mode.

Boone, the walker for threaded replies in bbPress depends on the following code being executed:
- https://github.com/bbpress/bbPress/blob/master/src/includes/replies/template.php#L212
- https://github.com/bbpress/bbPress/blob/master/src/includes/common/classes.php#L270

For some reason, $bbp->reply_query->found_posts was sometimes empty, which prevented the backfilling of the reply_to property for each bbPress post. I've added a hotfix for the threaded display in mu-plugins/ray.php, which injects the 'reply_to' property if it is missing. The relevant code is the bbp_has_replies filter. I will commit this later if I cannot determine how $bbp->reply_query->found_posts was wiped out.

I still have to work on the "Quote" button reply to issue.

#11 Updated by Boone Gorges about 1 year ago

Thanks for digging into this, Ray.

I will commit this later if I cannot determine how $bbp->reply_query->found_posts was wiped out.

Totally off the top of my head, but I wonder whether advanced-post-cache might be related?

#12 Updated by Raymond Hoh about 1 year ago

Totally off the top of my head, but I wonder whether advanced-post-cache might be related?

Good catch, Boone. I wasn't aware that this plugin was active on production.

This does seem to be the cause of the problem. I think the workaround I have in place will fix this problem for the bbPress replies loop. I will commit this in a bit.

I also noticed that the advanced-post-cache plugin does have some updates to disable certain post types from caching via new filters. We do have a custom patch to advanced-post-cache because our object cache uses a different signature: https://github.com/cuny-academic-commons/cac/commit/387d92f3625a6a2f18d6100a4930e8343cd8bba2#diff-acdec80a18202cfcf4a70a740d254a68. So that is something to keep in mind if we decide to update to the latest version.

#13 Updated by Boone Gorges about 1 year ago

  • Target version set to 1.17.4

Oh interesting - since WP 5.5 has cache multi-get support now, I should look into updating our drop-in. I'm guessing that advanced-post-cache will fix their own implementation upstream. I'll open a ticket for that.

#14 Updated by Boone Gorges about 1 year ago

  • Related to Bug #13346: Update cache drop-in to support wp_cache_get_multiple() added

#15 Updated by Raymond Hoh about 1 year ago

  • Category name set to Group Forums
  • Status changed from New to Staged for Production Release

Totally off the top of my head, but I wonder whether advanced-post-cache might be related?

Digging into this some more today, I found that this is a problem with the advanced-post-cache plugin when it caches post queries with no post limits and doesn't return the proper 'found_posts' count. I filed a report and added a PR here. Until they have addressed this, I've committed the bbPress workaround I mentioned above: https://github.com/cuny-academic-commons/cac/commit/878ad32838bf663c8eea954e40f54c8c7c474694

The "Quote" button doesn't use the reply ID. I can confirm that this is a bug.

I've addressed this in https://github.com/cuny-academic-commons/cac/commit/4678b8edd79e2c247c8954be12fddd449eb16001. This will be live tomorrow.

Both of the main issues in this ticket should now be addressed.


Oh interesting - since WP 5.5 has cache multi-get support now, I should look into updating our drop-in. I'm guessing that advanced-post-cache will fix their own implementation upstream. I'll open a ticket for that.

Looks like someone already filed a ticket about this: https://github.com/Automattic/advanced-post-cache/issues/20

Before this ticket is marked as resolved, I do want to return to what others mentioned above regarding the following:

we might consider some additional UI to make it clearer whether you've enabled threading (or even a quick link to toggle on a per-thread basis - didn't we once have this?)

Per-thread toggling was slated for #3192, but got pushed back and we never revisited this. Looks like this might be an opportune time to do this.

Either way, I do think a conversation around defaults and UI for forum settings would be useful at some point.

This can be related to the previous point.

The default display option on the forums is threaded for logged-in users. If you are logged out, it reverts to linear oldest. I think to be consistent here, we should make "linear oldest" the default display for everyone. However, those expecting the forum display to be threaded might find this sudden change jarring, so we'd probably need to introduce some type of notice to let people know of this new change. This could go together with the per-thread toggling feature if we decided to do this. We should probaly talk things through in a new ticket.

#16 Updated by Boone Gorges about 1 year ago

Both of the main issues in this ticket should now be addressed.

Thanks for digging into this so thoroughly.

I've opened https://redmine.gc.cuny.edu/issues/13358 to discuss UI improvements related to the defaults and a potential toggle.

#17 Updated by Boone Gorges about 1 year ago

  • Status changed from Staged for Production Release to Resolved

Also available in: Atom PDF