Project

General

Profile

Actions

Bug #13739

closed

My Sites and My Groups take user to the profile page

Added by Matt Gold almost 2 years ago. Updated 4 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Directories
Target version:
Start date:
2020-12-20
Due date:
% Done:

0%

Estimated time:

Description

Hi Boone -- when on either the main sites or groups pages, if one clicks "My Sites" or "My Groups," one is taken to that listing on one's profile page. I can't remember whether this is expected behavior; it seems wrong to me for users to be taken to the profile page at that point, as it moves them to a new interface, and it also seems (at least to my memory) like something that wasn't happening earlier -- before, clicking My Sites/Groups would show the user's sites/groups in the same interface


Files

Screen Shot 2021-09-07 at 3.38.59 PM.png (373 KB) Screen Shot 2021-09-07 at 3.38.59 PM.png Matt Gold, 2021-09-07 03:39 PM
dropdown.png (60.5 KB) dropdown.png Colin McDonald, 2022-05-16 06:19 PM
Screenshot_2022-05-16_19-55-28.png (26 KB) Screenshot_2022-05-16_19-55-28.png Boone Gorges, 2022-05-16 08:55 PM
Actions #1

Updated by Boone Gorges almost 2 years ago

  • Target version set to 1.19.0

These tabs may have been AJAX-powered in the past, but it likely wasn't recent. See eg https://github.com/cuny-academic-commons/cac/commit/637bf5f7edd3c4302f1df37063218bb2fd5f6a2a

Introducing AJAX navigation is complicated because of the interaction with other navigation tools on the page, such as the directory filters and pagination. But it should be possible to make it work in a non-AJAX way, by introducing a URL parameter to the top-level directories to limit results to those belonging to the current user.

I'm leaving this assigned to me because of the interaction with the directory filters introduced in 1.18.0, but I've added Ray as a watcher because he's done work on AJAX and nav tabs throughout the Commons in the past.

Actions #2

Updated by Matt Gold almost 2 years ago

Thanks, Boone. I'm almost certain that the My Sites link used to just trigger a filtering of the all sites listing within the same interface. But maybe I'm wrong! It seemed like Laurie remembered it working this way, too. I've cc'ed her here just for a sanity check (for me!)

Actions #3

Updated by Laurie Hurson almost 2 years ago

Hi All,

Yes, I noticed recently that when I click "my sites" when signed in, I am kicked over to my Commons profile page listing of my sites rather than seeing the "my sites" tab in the sites directory page (like it used to work).

For me, I find it much easier and more legible to view my sites listing through the sites directory within the main commons than be shifted into my profile page (since other main tabs like people, all groups, and courses are less accessible from my profile).

Actions #4

Updated by Matt Gold almost 2 years ago

I could have sworn that yesterday I clicked on "My Sites" and that it worked as it used to, showing "My Sites" within the Sites listing interface. but I just checked again and now I'm brought to my profile page to view My Sites. Is it possible that something might have changed yesterday and then changed back? Or maybe I am losing it!

Actions #5

Updated by Boone Gorges over 1 year ago

  • Category name set to Directories
Actions #6

Updated by Matt Gold about 1 year ago

Just had a reoccurrence of this. Screenshot attached. I got there by going to "Groups" > logging in > clicking "My Groups"

Actions #7

Updated by Boone Gorges 11 months ago

  • Target version changed from 1.19.0 to 2.0.0

I just took a few minutes to review. It looks like this probably changed after we redesigned the filter interfaces across Commons directories a couple version ago. That new filter interface, which includes Campus and Purpose filters, doesn't currently use AJAX. If we were to reintroduce an AJAX interface for 'My Groups', we'd need to decide whether to move all of the filtering to AJAX. At the very least, we'd need to ensure that the 'My Groups' filter either (a) takes account of the Campus and Purpose filter values, or (b) resets them in a way that doesn't feel frustrating for users. Let's explore this in a future release.

Actions #8

Updated by Boone Gorges 7 months ago

As part of the ongoing work on directory redesigns #15261, I've made the change for the Members directory. 'My Friends' now loads on the main directory, with URL commons.gc.cuny.edu/members/?scope=friends. See https://github.com/cuny-academic-commons/cac/commit/bdac770b08c3de8770da619c25539146e9825f62

At the moment, it's still not loading via AJAX. IMO this is probably okay, since presumably clicking one of these tabs should reset other filters (Campus, Keyword, etc). In any case, I can add AJAX reload as a progressive enhancement at a later date.

I'll port this over to the other directories as I continue work on them.

Actions #9

Updated by Colin McDonald 6 months ago

Thanks for keeping this ticket in mind, Boone. I'll put it on the list for testing to make sure we try it out across the directories.

Actions #10

Updated by Boone Gorges 6 months ago

  • Status changed from Assigned to Staged for Production Release

This is done for all directories that support 'My' tabs.

Actions #11

Updated by Colin McDonald 5 months ago

Hi Boone, trying to test this and make sure I'm in the right places. If I click one of My Sites/Friends/Groups on the dev site in the attached upper drop-down, it should take me to these respectively?

https://commons.gc.cuny.edu/sites/?scope=my-sites
https://commons.gc.cuny.edu/members/?scope=friends
https://commons.gc.cuny.edu/groups/?scope=my-groups

If so, I can't seem to be getting it to work, still going to the older "profile" interface.

Actions #12

Updated by Boone Gorges 5 months ago

Hi Boone, trying to test this and make sure I'm in the right places.

This is not the place that's addressed by the current ticket. The reference here is specifically to the 'My Groups' tab on the Groups directory, etc. See screenshot.

Actions #13

Updated by Colin McDonald 5 months ago

Got it, I misunderstood! Thanks, Boone.

Actions #14

Updated by Boone Gorges 4 months ago

  • Status changed from Staged for Production Release to Resolved
Actions

Also available in: Atom PDF