Project

General

Profile

Bug #13827

more forum post problems

Added by Marilyn Weber 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Group Forums
Target version:
Start date:
2021-01-12
Due date:
% Done:

0%

Estimated time:

Description

Via Zendesk:

I created a new group for a faculty development workshop that we run multiple times. I created the new group because when posting the forum questions to the old group, it was flagging duplicate topics (the questions and topics are the same between cohorts, but we want new topic threads for each new cohort of faculty answering the questions in the forum). Upon creating the new group, I'm getting the same error message about duplicate topics despite there not being any posts in the new forum (screenshot attached).

------------------
Submitted from: https://commons.gc.cuny.edu/groups/ccny-oer-workshop/forum/

Julia Brown

Duplicate Topic.jpg (129 KB) Duplicate Topic.jpg Marilyn Weber, 2021-01-12 07:44 PM

Related issues

Related to CUNY Academic Commons - Feature #13136: Post to multiple group forums by emailDuplicate2020-08-01

History

#1 Updated by Marilyn Weber 11 months ago

Argh, here's the screenshot.

Also, I'm asking her to let us know the URL of the old group.

#3 Updated by Boone Gorges 11 months ago

  • Category name set to Group Forums
  • Assignee set to Raymond Hoh

Ray, would you mind having a look? I thought we disabled the dupe-check for forum posts.

#4 Updated by Raymond Hoh 11 months ago

I thought we disabled the dupe-check for forum posts.

We are currently not disabling the duplicate check.

I just looked into the bbp_check_for_duplicate() function and it looks like when bbPress checks for duplicate topics, it doesn't check if the duplicate topic belongs to the specific forum (or group in our case), it checks across all forum threads. This seems a little too strict as evidenced by Julia's report. Whereas for duplicate forum replies, bbPress only checks the containing forum topic for a duplicate reply and not all forum replies.

One other data point I'd like to know is if this group was cloned or not. Was this new group created manually or through the group cloning process?

I think we might want to disable duplicate checks for forum topics only and this should solve our problem. We might get a few more instances of duplicate topics though, but I guess the group admin or poster can remove the topic manually themselves if a duplicate topic is encountered.

Also, this kind of ties in with #13136 and might help in solving that issue as well.

#5 Updated by Marilyn Weber 11 months ago

Ray, I asked about the creation and she replies The group was created manually.

#6 Updated by Boone Gorges 11 months ago

  • Target version set to 1.18.3

I think we might want to disable duplicate checks for forum topics only and this should solve our problem. We might get a few more instances of duplicate topics though, but I guess the group admin or poster can remove the topic manually themselves if a duplicate topic is encountered.

By 'only' you mean topics but not replies, right? This sounds like a reasonable path forward. Can you look into it, Ray? Feel free to punt if it's technically difficult.

#7 Updated by Marilyn Weber 11 months ago

Julia writes:

"It would be helpful to have a warning and then a "post anyway" option (I know this is also not an easy fix--just a suggestion)."

Is this possible while the problem is being worked on?

#8 Updated by Boone Gorges 11 months ago

A "post anyway" option is way harder than addressing the issue under the hood as proposed above. For the time being, unfortunately, the user will have to work around the problem by slightly modifying the content.

#9 Updated by Raymond Hoh 11 months ago

  • Status changed from New to Staged for Production Release

By 'only' you mean topics but not replies, right?

Yes, we will allow duplicate topics for now until bbPress addresses this problem. See https://github.com/cuny-academic-commons/cac/commit/6592df4233f6070d0957f069153f449e0d94826f. This hooks into the 'user_has_cap' filter to bypass this throttle check. Boone, let me know if I should push this as a hotfix to production.

I've also filed a ticket to bbPress Trac with a patch here.

#10 Updated by Marilyn Weber 11 months ago

Forgive my imperfect understanding - until it's a hotfix, duplicates cannot be posted?

#11 Updated by Raymond Hoh 11 months ago

That's correct, Marilyn. We have an upcoming maintenance release on the 26th, which would include the fix.

I wasn't sure if this issue was urgent enough to warrant a hotfix.

#12 Updated by Matt Gold 11 months ago

The solution here will be relevant to me, because I often send announcements by email to two groups (MA in Digital Humanities and MS in Data Analysis and Vis). Each time I send the second announcement, I make a slight alteration in the subject line (changing FWD to FW, for instance) and the body of the message to get by the dupe detection.

I'm a little unclear on the proposed solution here. Can you please help me understand where you have landed on this? Will duplicate forum posts now be allowed?

#13 Updated by Raymond Hoh 11 months ago

Hi Matt, as I mentioned in comment 4, this does tie in with posting topics to multiple groups via email.

I gave this a quick test and this will effectively solve that corresponding issue as well (#13136). You can add multiple group topic email addresses to your "To" header in your email client and this will post separate topics to each group if successful.

However, this has no tie in with the Multiple Forum Post plugin. So this means you will not see any metadata in the forum topic like "This topic was also posted to Group B". I think that is okay though. This also increases the likelihood for spam. If we encounter this, we might want to only allow duplicate topics for group admins when posting via email.

#14 Updated by Raymond Hoh 11 months ago

  • Related to Feature #13136: Post to multiple group forums by email added

#15 Updated by Marilyn Weber 11 months ago

Matt, can you weigh in on whether this should be a hotfix? Julia has been very patient. I think it'd be a nice thing to do.

#16 Updated by Matt Gold 11 months ago

Hi Ray -- if you wouldn't mind putting this through as a hotfix, I would appreciate it. But if that's an issue or problem, we can definitely wait until the next scheduled release.

#17 Updated by Raymond Hoh 11 months ago

  • Status changed from Staged for Production Release to Resolved

Applied as a hotfix to production.

Marilyn, can you let me know if Julia is able to post duplicate topics now?

#18 Updated by Marilyn Weber 11 months ago

Thanks - I've asked and will let you know.

Also available in: Atom PDF