Project

General

Profile

Bug #2129

[…]

Added by Matt Gold about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority name:
Low
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2012-09-14
Due date:
% Done:

0%

Estimated time:

Description

When I have a blog associated with a group and turn on the BuddyPress Group Email Subscription plugin, group members receive activity notifications of new posts. This is great, but I've noticed that notifications appear to show only truncated excerpts of the posts in question and that they all end with "[…]", the special character for ellipses, rather than ellipses themselves.


Related issues

Related to CUNY Academic Commons - Bug #2288: […] issue occurring on commonsinabox.orgRejected2012-11-21

Related to CUNY Academic Commons - Bug #2858: […] reduxResolved2013-10-30

History

#1 Updated by Boone Gorges about 9 years ago

  • Assignee changed from Boone Gorges to Dominic Giglio
  • Severity changed from Low impact to Trivial

Dom, you'll probably want to look in BuddyPress Group Email Subscription for this. If you come up with a general solution, pass it along to me, as I'm a maintainer for the plugin.

#2 Updated by Dominic Giglio about 9 years ago

OK, I'll let you know what I find as soon as I can get to this.

#3 Updated by Dominic Giglio about 9 years ago

Matt,

Just so I understand correctly, do you want full post content to be included in emails INSTEAD of an excerpt?

And, do you mean that the emails contain the literal string "& hellip ;" after the excerpt? (I had to add the spaces so that Redmine wouldn't automatically change that to '...').

If you could get a screenshot the next time you see this issue come up, that would be awesome. :-)

#4 Updated by Matt Gold about 9 years ago

Just so I understand correctly, do you want full post content to be included in emails INSTEAD of an excerpt?

I would love to see full post content, but that should be a different ticket

And, do you mean that the emails contain the literal string "& hellip ;" after the excerpt? (I had to add the spaces so that Redmine wouldn't automatically change that to '...').

Yes, the literal string. Screenshot attached.

#5 Updated by Dominic Giglio about 9 years ago

Matt,

In Issue #1997 I raised a concern that the problem causing that issue could be related to this one and the issue you brought up in #2129 (missing hyperlinks in forum notification emails). Boone is looking into the cause of those missing hyperlinks and whether it's related to code changed in GES.

I'm wondering if you've seen any recent emails that still display the [& hellip ;]? I'm curious as to whether the solution in #1997 has magically resolved this issue. :-)

#6 Updated by Dominic Giglio about 9 years ago

Sorry, my last update should have read:

the issue you brought up in #2121 (missing hyperlinks in forum notification emails)

#7 Updated by Matt Gold about 9 years ago

I'm wondering if you've seen any recent emails that still display the [& hellip ;]?

Yes, still seeing them, unfortunately -- please see attached.

#8 Updated by Boone Gorges about 9 years ago

  • Status changed from Assigned to Resolved
  • Assignee changed from Dominic Giglio to Boone Gorges

I tried reproducing this, but couldn't do so. So I just wrote a function that would put the entire content of the blog post into the notification; since it won't be truncated, there won't be an hellip character appended. Thus the problem is skirted. https://github.com/castiron/cac/commit/2721004c0d2a2d4121ea535ffa9c679d2cb99dee

#9 Updated by Matt Gold about 9 years ago

Fantastic. Thanks, Boone.

Also available in: Atom PDF