Project

General

Profile

Feature #2271

CBOX forum posts include "notify by email" checkbox

Added by Matt Gold about 9 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
commonsinabox.org
Target version:
Start date:
2012-11-18
Due date:
% Done:

0%

Estimated time:

Description

Underneath the group forum posting box is a "NOTIFY ME OF FOLLOW-UP REPLIES VIA EMAIL" checkbox. How does this relate to group email subscriptions?

History

#1 Updated by Raymond Hoh about 9 years ago

The new bbPress plugin has email subscriptions built-in for anyone subscribed to the topic, while the BuddyPress Group Email Subscription plugin is tailored for BuddyPress groups.

The BuddyPress Group Email Subscription plugin is not compatible with the new bbPress plugin yet; some development time will be needed to add this functionality.

#2 Updated by Matt Gold about 9 years ago

Thanks, Ray. I guess the question is whether the box should be hidden when Group Email Subscription is active. I can see a few viewpoints:

1. Hide it because users may find it confusing -- they might think they have to check the checkbox to get email updates, even though they already are getting email updates via group email subscriptions (GES hereafter)

2. Show it because it opens options for users -- they can have GES set to no email but can subscribe to individual threads if they choose

#3 Updated by Chris Stein about 9 years ago

I would go with (1) hide it for now, until we can better work out how to deal with the two email subscription routes (bbPress and BuddyPress). I think the number of people who want to subscribe on a per thread basis get trumped by the possible confusion and people will still be able to use the BuddyPress email subscription options.

#4 Updated by Boone Gorges about 9 years ago

  • Target version set to Not tracked

people will still be able to use the BuddyPress email subscription options.

Yes, but as Ray notes, BP email subscription options do not currently cover these new bbPress forums. So if we hide the UI, there will be no way for people to receive email notification of new forum content.

I'm assuming here that we're talking about Commons In A Box itself, where standalone bbPress forums are possible. If we're talking about commonsinabox.org, then we could probably remove the box and assume that users will get notifications of the activity items created by forum posts (that's right, isn't it Ray?)

#5 Updated by Boone Gorges about 9 years ago

  • Tracker changed from Bug to Feature

#6 Updated by Matt Gold about 9 years ago

small side note: Boone, if we're going to continue to use this Redmine install for both CBOX and commonsinabox.org tickets, perhaps we should create separate categories for them? Your call

#7 Updated by Boone Gorges about 9 years ago

Boone, if we're going to continue to use this Redmine install for both CBOX and commonsinabox.org tickets, perhaps we should create separate categories for them

We're not going to use it for Commons In A Box. We have Github trackers for that. If people don't feel comfortable posting tickets there, they can post them here under n'importe quel category, and Ray or I will move them as appropriate.

#8 Updated by Matt Gold about 9 years ago

Okay. So is your preference for both CBOX and commonsinabox.org tickets to be on Github, or just CBOX tickets?

#9 Updated by Boone Gorges about 9 years ago

Use Redmine for commonsinabox.org tickets, because commonsinabox.org is a private website that only I have the ability to modify, while Commons In A Box is the software project that anyone can contribute to.

#10 Updated by Boone Gorges about 9 years ago

Adding Ray as watcher so he remembers to check back here

#11 Updated by Raymond Hoh about 9 years ago

I'm assuming here that we're talking about Commons In A Box itself, where standalone bbPress forums are possible. If we're talking about commonsinabox.org, then we could probably remove the box and assume that users will get notifications of the activity items created by forum posts (that's right, isn't it Ray?)

Boone, about the latter point, you're right, GES automatically supports anything recorded into the group activity stream.

However, if you edit a bbPress group forum post, another email will be sent. We'll need to fix this for GES; I'll add an issue on Github for this.

Also, GES currently has some advanced features like:
  • A member replies in a forum topic you've started
  • A member replies after you in a forum topic
  • Receive notifications of your own posts?

I think these features are enhancements and we could look into supporting those in a future release of GES past the CBOX launch window.


About hiding the subscription checkbox, I think we could hide bbPress' subscription checkbox if we're on a BuddyPress group topic; if we're on a regular bbPress forum topic, then leave it as-is.

The caveats with this approach is the subscription checkbox will be hidden in one instance and shown in another instance, which means the UI won't be consistent. I think this is rather minor though, but some users might bring up this point.

#12 Updated by Boone Gorges about 9 years ago

  • Status changed from Assigned to Reporter Feedback

Thanks, Ray. You've confirmed what I already suspected.

For Commons In A Box itself, I say we leave things the way they are. The worst that will happen with the additional checkbox is that people will get two notifications. In the medium to long term, we should think about reworking GES so that it works for more than just groups, as you suggest above. Email notifications in BuddyPress are pretty mediocre, so there's a lot of work that we could potentially do in a plugin overhaul.

As for commonsinabox.org, if Matt and Chris think the additional box is confusing, we can hide it. I don't care one way or the other. And in the case of commonsinabox.org, there are no group-independent forums anyway, so everything will be covered by GES.

#13 Updated by Matt Gold about 9 years ago

Thanks, Boone. I'm down with everything you say above, but I do think we should hide the box in commonsinabox.org

#14 Updated by Chris Stein about 9 years ago

I signed out for Thanksgiving and missed some great clarification from Ray and Boone. Thanks, that makes it much clearer. I don't have much to add. I agree that it's fine to remove the checkbox for commonsinabox.org

For CBOX I agree with Boone and Ray that, for now things may be best left as they are, and that integration with GES in the long term is the way to go.

If you wanted to do any short term bandaid work for CBOX the only thing that I can think of is to make the text around the checkbox more verbose.
1) CURRENT: NOTIFY ME OF FOLLOW-UP REPLIES VIA EMAIL
2) SLIGHTLY MORE: NOTIFY ME OF FOLLOW-UP REPLIES TO THIS TOPIC VIA EMAIL

I thought of adding a third option which was even more verbose and explained the situation but it got too long and was possibly more confusing. Duplicate emails are probably less confusing in the end.

If/when this is revisited we should also address the "Subscribe" link at the top of the page (It appears to be the same thing as checking the checkbox but the different wording on the two, subscribe/notify, doesn't make that clear).

#15 Updated by Raymond Hoh about 9 years ago

Just to update everyone, Boone and I have made some code changes in Group Email Subscription that will temporarily address this problem.

We've hidden the bbPress subscription checkbox when you're on a BuddyPress group.

#16 Updated by Matt Gold about 9 years ago

Great -- thanks!

#17 Updated by Matt Gold almost 9 years ago

For the cbox site, I think that part of the reason I'm seeing double notifications (http://redmine.gc.cuny.edu/issues/2343) is that I'm subscribed in two ways: through BP group settings and through the BbPress checkbox, which I checked before it was hidden.

Now that the checkbox is hidden, I don't think there's a way for me to uncheck the BbPress settings, right? For people in my situation (or just for me if I'm the only one in this situation) would it be worth doing the following:

1. Seeing who is subscribed through BbPress settings and manually unsubscribing them
2. Subscribing those same people through BP Group email settings if they are not already receiving notifications

This would have the result of having people subscribed through only one option and allowing them to be able to adjust that option. Thoughts?

#18 Updated by Boone Gorges almost 9 years ago

would it be worth doing the following

It'll take me an hour or two, so IMO it's not worth doing, but feel free to override and I will get to it sometime next week.

#19 Updated by Matt Gold almost 9 years ago

What if we take this in stages, with the first one being a quick check (next week or whenever) to see how many people this is affecting. That affects the worth-the-time question for me. If you could do that, I'd appreciate it. Thanks!

#20 Updated by Raymond Hoh almost 9 years ago

Hi Matt:

For the cbox site, I think that part of the reason I'm seeing double notifications (http://redmine.gc.cuny.edu/issues/2343) is that I'm subscribed in two ways: through BP group settings and through the BbPress checkbox, which I checked before it was hidden.

I added a code snippet to cbox.org to disable the bbPress plugin from sending any emails.

I believe your double notifications issue is the result of cbox.org not running the latest version of GES; I think if we update GES on cbox.org, then this issue should resolve itself.

#21 Updated by Matt Gold almost 9 years ago

Cool - thanks, Ray!

#22 Updated by Boone Gorges almost 6 years ago

  • Status changed from Reporter Feedback to Resolved

It sounds like the issues on commonsinabox.org have been resolved.

Also available in: Atom PDF