Project

General

Profile

Feature #28

Add threaded replies to forum posts

Added by Matt Gold almost 13 years ago. Updated over 7 years ago.

Status:
Resolved
Priority name:
Low
Assignee:
Category name:
Group Forums
Target version:
Start date:
2009-09-25
Due date:
% Done:

0%

Estimated time:

Description

This request came in from the ITP Group. It's a good idea. We should see whether any BbPress plugins exist to accomplish this.

History

#1 Updated by Matt Gold almost 13 years ago

  • Status changed from New to Assigned

#2 Updated by Boone Gorges almost 12 years ago

It looks like there aren't any very good options for this at the moment. The plugins that make this work in bbPress are all broken, and anyway would need significant modification to work with the BP installation of bbPress.

Another consideration is that bbPress is currently being rewritten, and its relationship with BP will probably be changing significantly in the course of the next four months or so. To me, this suggests that we wait until early 2011 to assess the possibility.

Unless, of course, we determine that it's really important to implement it sooner. In that case, I can start taking a look at the necessary customizations sooner. My judgment that this is not the most efficient use of our dev resources is entirely dependent on the extent of the need for this feature.

#3 Updated by Boone Gorges almost 12 years ago

  • Target version set to Future release

#4 Updated by Matt Gold over 11 years ago

This came up yesterday during the Subcommittee meeting, Boone. Can you check to see whether others have made any progress on this? Thanks.

#5 Updated by Matt Gold over 11 years ago

  • Target version changed from Future release to 1.2

#6 Updated by Boone Gorges over 11 years ago

  • Target version changed from 1.2 to Future release

I have talked to John Jacoby, who is developing the bbPress plugin. He said that the plugin does not support threaded discussions natively, but that it could be patched to do so. I'll have a look at it and submit the patches myself. However, this will only be applicable for the Commons once BP has been refactored to use the new bbPress plugin, which will probably be in the second half of 2011.

In the meantime, it is probably possible for me to build something that apes the feature. (Anything is possible.) I would have to do more research about just how hard it would be. At the very least, it will be a moderately large amount of work. At most, it will amount to completely rewriting the entire forum component. I do not want to hold up the next version of the Commons for it.

So the remaining question is whether it's worth limited dev resources to build this now rather than to wait 6-9 months to have it as part of the native bbPress/BP package. I feel pretty strongly that it is not worth it. We have come this far without it, and it would essentially mean spending 10, 20, 30 hours of expensive development time on something that will have to be rebuilt (possibly by me, as part of my role in core BP development) when the time comes. I'm willing to be overruled on this one, if the need for it is so great that people are going to leave the Commons in the absence of threaded forums. Otherwise I think we should wait.

#7 Updated by Matt Gold over 11 years ago

I agree with you on this, Boone, with the caveat that it would be great if you could remain in active contact with JJJ as he develops the plugin so that we could go live with it soon after he releases it.

Michael, since you are one of the biggest proponents of this, what do you think?

#8 Updated by Chris Stein over 11 years ago

It makes sense to me too, to wait until the official version is released. I think at this point it is nice to have for some and not a deal breaker for most ( but will be appreciated when it gets here).

#9 Updated by Michael Smith over 11 years ago

I mentioned that it would be great to track the feature list for this plugin in the discussion of Quote Features in Forums. I think these features are related as they both impact how we view and interact with forums.

I think there's really a lot that can happen to improve the viewing of forum posts and activity streams as well. The ability to thread forums, and potentially other activity streams such as comments to blog posts would have the potential to affect the way people spend time on the site.

Right now, I'm mostly connected to the Commons through my email which notifies me of activity that I'm interested in tracking.

But if was able to go to the My Activity page, and filter by members, groups, adding or removing specific ones from what I want to view. Then see threaded forums, blog comments, etc. And finally be able to respond inline for any of these – that would allow me to spend most of my time in one place on the Commons. I would more likely start to spend time just on the site monitoring activity rather than my email.

I imagine that would require a lot of development, and I don't really have enough of a sense of the time involved so, please let me know if this is too fanciful right now.

#10 Updated by Boone Gorges almost 8 years ago

  • Status changed from Assigned to Resolved
  • Target version changed from Future release to 1.7

We get this for free with the move to bbPress 2.x. See #3177. I've made a note to enable it when 1.7 goes live.

Marking resolved.

#11 Updated by Matt Gold almost 8 years ago

Excellent.

#12 Updated by Sarah Morgano over 7 years ago

  • Status changed from Resolved to Reporter Feedback

I just tested this and it's not working for me. Is that because you need to enable it when 1.7 goes live?

#13 Updated by Boone Gorges over 7 years ago

Sarah, can you please let me know where you tested (URL), and a further explanation of what you mean by "it's not working for me"?

#14 Updated by Sarah Morgano over 7 years ago

I was testing threaded replies with this topic: http://cdev.gc.cuny.edu/groups/scotts-test-group/forum/topic/this-is-a-test-topic/.

I replied to this post http://cdev.gc.cuny.edu/groups/scotts-test-group/forum/topic/this-is-a-test-topic/#post-29093 and I thought it would appear indented directly underneath that post, but it shows up at the bottom of the thread not indented.

#15 Updated by Boone Gorges over 7 years ago

Thanks, Sarah - not sure why it's not working. I'll take a look.

#16 Updated by Boone Gorges over 7 years ago

  • Status changed from Reporter Feedback to Assigned
  • Assignee changed from Boone Gorges to Raymond Hoh

Ray, it looks like 'bp_fus_thread_replies' is overriding the admin-set level. Can we change how the default works? Instead of defaulting to false, if no user-level setting exists, default to the admin-level setting.

#17 Updated by Raymond Hoh over 7 years ago

Boone - I've added better defaults when the "Threaded Display" option isn't set by the user yet. See commit 86abde5.

Sarah - Previously, if you did not set the "Threaded Display" option under "My Settings > Forums", it would default to oldest linear display. The newest update should now default to whatever the admin has set in the WP admin dashboard.

To be sure, can you navigate to "My Settings > Forums" and make sure the "Threaded Display" option is set to "Threaded"? If it's not set to Threaded, set it to Threaded and then navigate to a forum thread. Forum posts should show up as threaded replies now.

#18 Updated by Raymond Hoh over 7 years ago

  • Status changed from Assigned to Reporter Feedback

I think the latest changes fixes the problems that Sarah was experiencing.

Can someone verify before I mark this issue as resolved?

#19 Updated by Matt Gold over 7 years ago

  • Status changed from Reporter Feedback to Resolved

Confirmed. Thank you, Ray! And nice catch, Sarah.

Also available in: Atom PDF