Project

General

Profile

Bug #4876

New user profile setup bug

Added by Lisa Rhody over 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Registration
Target version:
Start date:
2015-11-09
Due date:
% Done:

0%

Estimated time:

Description

Hi!

When creating a new profile, I experienced the following two issues using Firefox on a Mac OSX Yosemite 10.10.5 machine: the "your profile" link does not open a new page because the page is already open underneath; dismissing a notification does not actually dismiss the notification; and changes are not saved to the public profile. Description below.

Upon first login, I was directed to the "Your profile has changed" notification window. The notification window appears on top of the Edit your Profile page. When clicking on the link associated with "Visit your profile" at the bottom, there appeared to be no action, because the page is already open underneath of the notification window, but not visible enough so that the user can see that it's there.

Note: The "Your profile has changed" notification box says the following: "Visit your profile page and click the Edit button there to get started." When you dismiss the "Your profile has changed" window, there is no Edit button on the "Your Profile" editing page... and there are no buttons in green (user expectation here being that a green Edit will appear). There are blue "save changes buttons."

In on the new user profile page, clicking the "change your photo" link redirects the user to the "Your Commons profile now has a required field" notification window. Dismissing this window will allow the user to go back to the edit profile page. This loop occurs endlessly.

However, if the user then changes information in the required profile fields and clicks "Save Changes" the changes appear to save. However, if the user then clicks on "Change Photo," the user is kicked back into the same notification loop ("Your Commons profile now has a required field").

Clicking "Sure! Take me to my Commons Profile now" takes the user back to the profile page where none of the data was actually saved and all completed fields are now blank again. The name returns to the original user id, and all other fields are empty.

It may be of use to note that any changes made in the "About You" field does not register on the characters counter below the field. I can type 5 or 200 characters, but the counter reads 0 out of 350 characters.

Finally, I tried the "save changes" button at the very bottom of the page. That one appeared to work. However, it doesn't look like it did, because when I clicked on another part of the commons, the "Your Commons profile now has a required field" window popped up again.

Please let me know if I can supply additional information!

History

#1 Updated by Matt Gold over 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

And with this bug report, we welcome Lisa to the GC!!

#2 Updated by Lisa Rhody over 3 years ago

  • Assignee deleted (Boone Gorges)

Matt Gold wrote:

And with this bug report, we welcome Lisa to the GC!!

:-) Hi, Boone!

#3 Updated by Lisa Rhody over 3 years ago

  • Assignee set to Boone Gorges

#4 Updated by Boone Gorges over 3 years ago

  • Category name set to Registration
  • Target version set to 1.8.16

Hi Lisa! Welcome!

Also, ugh. Thanks for the thorough report. All the annoying fields that you're seeing are not intended to be shown to new users. I'm going to go through and try to make sure that new users don't, in fact, see them.

On a first pass, I can't reproduce the Save Changes and About You bugs you've described. Those sound related - it's likely that something is killing the JavaScript on one part of the page, which is killing all other JavaScript on the page.

#5 Updated by Boone Gorges over 3 years ago

  • Status changed from Assigned to Reporter Feedback

In https://github.com/cuny-academic-commons/cac/commit/6ad474ca0020df883232f14cb071056c9f11f4fa and https://github.com/cuny-academic-commons/cac/commit/a1df3f864a9e7b6374690c9438eb34f76aade692 I modified the overlay notifications so that they don't display for new users (or anyone whose account was created after the new features were launched).

These changes will be live after the 1.8.16 release, on November 11.

Lisa, if you continue to have problems with Save Changes and the About You character count when editing your profile, could I ask you to open your browser's JS console to see what kinds of error notices it's displaying?

#6 Updated by Lisa Rhody over 3 years ago

Hi Boone...

Here's the JS error that I'm getting in my Firefox console:

When I click inside the "About me" box and type:
ReferenceError: update_character_count_for_field is not defined <13> cacap.js:211:42

Save changes results in these two error statements:
unreachable code after return statement admin-bar.js:3:1
unreachable code after return statement admin-bar.js:3:1

Hope that helps!

#7 Updated by Boone Gorges over 3 years ago

  • Target version changed from 1.8.16 to 1.8.17

Thanks, Lisa! The character-counting bit was indeed a bug, which is fixed by https://github.com/cuny-academic-commons/cac-advanced-profiles/commit/b7ba27871a28c019a90589a3ac40619d2789eba1

I don't know whether this will address your profile saving issue. I'm going to move this ticket to the next milestone so that we can continue to test after the 1.8.16 release.

#8 Updated by Boone Gorges about 3 years ago

  • Target version changed from 1.8.17 to 1.8.18

Lisa, when you get a moment, could I ask you to see whether you continue to experience the same problem when saving your profile?

#9 Updated by Raymond Hoh about 3 years ago

  • Target version changed from 1.8.18 to 1.9

#10 Updated by Boone Gorges about 3 years ago

  • Target version changed from 1.9 to 1.9.1

#11 Updated by Boone Gorges about 3 years ago

  • Target version changed from 1.9.1 to 1.9.2

#12 Updated by Boone Gorges about 3 years ago

  • Target version changed from 1.9.2 to 1.9.3

#13 Updated by Boone Gorges about 3 years ago

  • Target version changed from 1.9.3 to 1.9.4

#14 Updated by Boone Gorges about 3 years ago

  • Target version changed from 1.9.4 to 1.9.5

#15 Updated by Boone Gorges about 3 years ago

  • Target version changed from 1.9.5 to 1.9.6

#16 Updated by Boone Gorges about 3 years ago

  • Target version changed from 1.9.6 to 1.9.7

#17 Updated by Boone Gorges about 3 years ago

  • Target version changed from 1.9.7 to 1.9.8

#18 Updated by Boone Gorges almost 3 years ago

  • Target version changed from 1.9.8 to 1.9.9

#19 Updated by Lisa Rhody almost 3 years ago

Hi Boone,
It appears to be fixed. Sorry for the delay!
Best,
Lisa

#20 Updated by Boone Gorges almost 3 years ago

  • Status changed from Reporter Feedback to Resolved

Excellent! Thanks, Lisa.

Also available in: Atom PDF