Project

General

Profile

Bug #6286

Groups pages not displaying at all!

Added by Marilyn Weber almost 3 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority name:
Immediate
Assignee:
Category name:
Groups (misc)
Target version:
Start date:
2016-10-14
Due date:
% Done:

0%

Estimated time:

Description

Katina Rogers reported:
"Groups pages are silently failing for me; the following pages will not load but display only an empty browser window, no error message:

https://commons.gc.cuny.edu/groups/digital-humanities-initiative/
http://commons.gc.cuny.edu/groups/

I'm using Chrome and the error occurred at 9:42am on Friday, 10/14. I don't need any follow-up or support, just reporting the error."

I'm also using Chrome and am seeing the same thing. Two screenshots attached.

DHIBlank.JPG (31 KB) DHIBlank.JPG Marilyn Weber, 2016-10-14 10:13 AM
GroupsBlank.JPG (325 KB) GroupsBlank.JPG Marilyn Weber, 2016-10-14 10:13 AM
Screen Shot 2016-10-14 at 11.18.46 AM.png (162 KB) Screen Shot 2016-10-14 at 11.18.46 AM.png Matt Gold, 2016-10-14 11:19 AM

Related issues

Related to CUNY Academic Commons - Bug #6310: Members of groups kicked out of the group including ownersDuplicate2016-10-14

Related to CUNY Academic Commons - Bug #6313: group member no longer in group, can't rejoin. Duplicate2016-10-14

History

#1 Updated by Matt Gold almost 3 years ago

  • Category name set to Groups (misc)
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
  • Priority name changed from High to Immediate

Boone -- are you around to take a look at this?

#2 Updated by Marilyn Weber almost 3 years ago

Both now work for me, at 10:31

#3 Updated by Marilyn Weber almost 3 years ago

Wait - they mostly work. Neither shows avatars.

#4 Updated by Matt Gold almost 3 years ago

I'm still getting failures on http://commons.gc.cuny.edu/groups/

#5 Updated by Boone Gorges almost 3 years ago

Looking.

#6 Updated by Boone Gorges almost 3 years ago

While I'm debugging this, if anyone is able to reproduce reliably, please do the following:

- Append ?bbgd=1 to your URL and reload the page. This will activate a temporary debug mode.
- Take a screenshot of error messages and upload it here

#7 Updated by Matt Gold almost 3 years ago

Hi Boone -- this is from the Groups page. Mac / Chrome

#8 Updated by Boone Gorges almost 3 years ago

This appears to be a bug in the latest version of Chrome. I'm continuing to investigate workarounds.

#9 Updated by Boone Gorges almost 3 years ago

I've got a workaround in place. Can I get confirmation that it's working? I'm still looking into root causes.

#10 Updated by Matt Gold almost 3 years ago

Yes, confirmed that this is working for me. thank you so much, Boone.

#11 Updated by Boone Gorges almost 3 years ago

  • Target version set to Not tracked

The deepest cause I can be sure of is that Chrome is not receiving the end character of some chunk of the page, and is therefore refusing to render it. See http://stackoverflow.com/questions/29894154/chrome-neterr-incomplete-chunked-encoding-error/29990521 for one thread describing the issue.

This error can happen for many different reasons: a fatal error in an output buffers, Apache sending the wrong Content-Length header, improper gzip compression settings. The fact that the issue just started happening makes me think there may be a recent server change or a recent browser upgrade to blame, though it's not clear to me what it would be. I'll follow up with Lihua to rule out some possibilties.

I was able to find a workaround for the moment: disabling opcache. See http://stackoverflow.com/a/29970732. I have no idea why this fixes it. Ray, any thoughts?

#12 Updated by Matt Gold almost 3 years ago

  • Target version deleted (Not tracked)

Hi Boone -- two questions:

-- will this affect CBOX sites?
-- is this a BuddyPress-wide issue?

#13 Updated by Matt Gold almost 3 years ago

(I am seeing NYCDH groups with a problem)

#14 Updated by Boone Gorges almost 3 years ago

As described above, I'm afraid I don't have any idea about the root cause. I'll follow up if/when I have more info.

#15 Updated by Boone Gorges almost 3 years ago

  • Target version set to Not tracked

#16 Updated by Raymond Hoh almost 3 years ago

I'm trying to duplicate this on cdev, but I cannot. Tested on Chromium 56.0.2888.0 and Chrome 51.

Maybe this only occurs on production?

#17 Updated by Raymond Hoh almost 3 years ago

  • Related to Bug #6310: Members of groups kicked out of the group including owners added

#18 Updated by Raymond Hoh almost 3 years ago

  • Related to Bug #6313: group member no longer in group, can't rejoin. added

#19 Updated by Raymond Hoh almost 3 years ago

  • Status changed from Assigned to In Progress

Boone did some investigating and found out that one of our memory caching instances was failing, which was probably the cause of all the other issues today (#6310, #6313).

To temporarily resolve this, we have disabled the instance causing the failure. We will relay this info to Lihua to see if he can run down the cause of the problem.

#20 Updated by Boone Gorges almost 2 years ago

  • Status changed from In Progress to Resolved

Haven't seen this problem recur, so I'm closing.

Also available in: Atom PDF