Project

General

Profile

Bug #6695

Member reply to announcement goes to Commons address

Added by Matt Gold over 5 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority name:
Normal
Assignee:
Category name:
Group Announcments
Target version:
Start date:
2016-11-14
Due date:
% Done:

0%

Estimated time:

Description

A member in a group replied to an announcement; the reply went to the Commons email address. This seems like a similar issue to what we saw in ticket #6674

Screenshot attached


Related issues

Related to CUNY Academic Commons - Bug #6674: Member RBE responses to document uploadsResolved2016-11-11

Related to CUNY Academic Commons - Feature #3175: Replace Announcements with a force-email option on new forum postsResolved2014-04-25

History

#1 Updated by Matt Gold over 5 years ago

  • Related to Bug #6674: Member RBE responses to document uploads added

#2 Updated by Boone Gorges over 5 years ago

  • Assignee changed from Boone Gorges to Raymond Hoh
  • Target version set to 1.10.2

Ray, is this a regression? I can't remember whether RBE natively handles our group announcements (which are standard BP activity items).

#3 Updated by Raymond Hoh over 5 years ago

This sounds like a regression.

We disabled RBE for group announcements, but this looks to have broken since using the new BuddyPress email system.

This is probably due to the way I had to reconfigure RBE so it would work with BP emails. Probably an action/filter firing order issue.

Will look into it.

#4 Updated by Raymond Hoh over 5 years ago

The non-RBE notice should be back again. See:
https://github.com/cuny-academic-commons/cac/commit/53b293d3818fb3d46473d028f8b458d109c690ea

This is available for testing on cdev.

As for the reply to the group announcement itself, I forget what we did in the previous iteration of emails. Where did replies to non-RBE content go to? commons@gc.cuny.edu or cunycommons@gmail.com or some other email address?

#5 Updated by Matt Gold over 5 years ago

Hi All --

Have we instituted the feature where "announcements" are deprecated but group admins have the ability to force their messages out to everyone, regardless of email setting? If so, I think RBE should be enabled on announcements, since they'll just be like forum posts but ones that have also been forced out via email. I would say that replies to announcements should not override user email preferences. Thoughts?

#6 Updated by Boone Gorges over 5 years ago

Have we instituted the feature where "announcements" are deprecated but group admins have the ability to force their messages out to everyone, regardless of email setting?

Not yet. https://redmine.gc.cuny.edu/issues/3175

If so, I think RBE should be enabled on announcements, since they'll just be like forum posts but ones that have also been forced out via email. I would say that replies to announcements should not override user email preferences. Thoughts?

This seems right to me.

#7 Updated by Boone Gorges over 5 years ago

  • Related to Feature #3175: Replace Announcements with a force-email option on new forum posts added

#8 Updated by Boone Gorges over 5 years ago

As for the reply to the group announcement itself, I forget what we did in the previous iteration of emails. Where did replies to non-RBE content go to? or or some other email address?

I thought they went to the RBE email address, which then responded that the particular item doesn't support replying by email.

#9 Updated by Raymond Hoh over 5 years ago

If so, I think RBE should be enabled on announcements, since they'll just be like forum posts but ones that have also been forced out via email. I would say that replies to announcements should not override user email preferences. Thoughts?

There was a reason why we disabled RBE for group announcements. See #2686.

People cannot reply to group announcements on the frontend, so we chose to disable RBE for group announcements as well. Also, only those subscribed via the group's "All Mail" option could reply to group announcements.

We can revert this behavior, but I think #3175 might be more appropriate to turn RBE back on for group announcements.

#10 Updated by Boone Gorges over 5 years ago

We can revert this behavior, but I think #3175 might be more appropriate to turn RBE back on for group announcements.

I agree with this. Does that mean there's nothing left to do on this ticket?

#11 Updated by Boone Gorges over 5 years ago

  • Target version changed from 1.10.2 to 1.10.3

#12 Updated by Raymond Hoh over 5 years ago

  • Status changed from Assigned to Duplicate

I agree with this. Does that mean there's nothing left to do on this ticket?

That's correct. Let's close this in favor for #3175.

Also available in: Atom PDF