Project

General

Profile

Feature #9943

Site templates

Added by Boone Gorges 11 months ago. Updated 6 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2018-06-15
Due date:
% Done:

0%

Estimated time:

Description

We've been calling these "theme templates" in our initial discussions, though they're much more than "themes". "Site template" is more technically correct. We might decide on some other language for user-facing interface.

1. Team will create a list of named templates ("Teaching Template", etc)
2. Each template will have its own "master template site", which is a site that contains the configuration to be inherited by new sites using the template. This includes default content, config, navigation, etc. See https://docs.google.com/document/d/19yWcamz-cuNZDR4HTUkYphypNLnA14Mg-RVRqC4l0f4/edit#heading=h.es7p5ju9ga3a for an outline.
3. There will be a public-facing demo site for each template. I think it makes sense for this to be separate from the (private) master template site, though we can talk about this. (It's certainly easier for them to be unified, as a separate demo site will need to be re-propagated each time there's an update to the master. But I think that they have to be separate, so that stuff like comments don't get synced over.)
4. A new interface will appear on the /sites/create screen that will allow the user to select the site template for the new site. This interface will have a list of template names, brief descriptions, and links to the demo site.
5. The newly created site will be cloned from the template site.
6. We'll keep track of the fact that a site was created from a specific template, likely using the same mechanism as in #9942 for tracking plugin package activation.

Screenshot_2018-08-17_11-39-43.png (100 KB) Screenshot_2018-08-17_11-39-43.png Front-end interface Boone Gorges, 2018-08-17 01:14 PM
Peek 2018-08-17 11-39.gif (861 KB) Peek 2018-08-17 11-39.gif site creation interface Boone Gorges, 2018-08-17 01:15 PM
Peek 2018-08-17 11-40.gif (607 KB) Peek 2018-08-17 11-40.gif Boone Gorges, 2018-08-17 01:16 PM
Screenshot 2018-10-28 07.57.56.png (1.43 MB) Screenshot 2018-10-28 07.57.56.png Stephen Real, 2018-10-28 08:04 AM
default-template-demo-screenshot.png (210 KB) default-template-demo-screenshot.png Luke Waltzer, 2018-11-12 10:08 AM
teaching-template-demo-screenshot.png (1.02 MB) teaching-template-demo-screenshot.png Luke Waltzer, 2018-11-12 10:08 AM
academic-portfolio-template-screenshot.png (662 KB) academic-portfolio-template-screenshot.png Luke Waltzer, 2018-11-12 10:08 AM
Screenshot_2018-11-13_13-24-31.png (104 KB) Screenshot_2018-11-13_13-24-31.png Boone Gorges, 2018-11-13 02:28 PM
Screenshot_2018-11-13_13-24-42.png (162 KB) Screenshot_2018-11-13_13-24-42.png Boone Gorges, 2018-11-13 02:28 PM

Related issues

Related to CUNY Academic Commons - Feature #7112: Add Copyright option/question to users on blog creation wizardResolved2016-12-16

Related to CUNY Academic Commons - Bug #10595: Confirmation page after site creation has double footerResolved2018-10-25

Related to CUNY Academic Commons - Feature #10712: Open Site Template demo links in new window?Resolved2018-11-16

Has duplicate CUNY Academic Commons - Feature #502: Create Site TemplatesDuplicate2010-12-19

History

#1 Updated by Boone Gorges 9 months ago

I've completed a first pass at the new plugin. https://github.com/cuny-academic-commons/cac-site-templates

An attached screenshot shows the front-end interface. Briefly, the selector is a radio button selector, with an introductory paragraph. Each option has a name, an image, a demo site link, and a description. Suggestions for improvement are welcome here. (I also attached a gif of walking through the process, which shows you that I've done some styling tweaks to the site creation page more generally to support the new section.)

Another gif shows the Gutenberg-based Dashboard interface.

One initial question is regarding the "default" value. For clarity, I think we need to make the Template a required field. The current defaults when you create the site could then be called the "default" template, or "blog" or "minimal" template, or something like that. Does that make sense to others?

It will be much easier to critique the interface once we have some real content (template names, images, etc), but any initial thoughts are welcome.

#2 Updated by Matt Gold 9 months ago

Thanks for your great work on this, Boone. It looks really good.

My understanding from our previous discussions was that people would have the option to use a template or not. I think I see the reasoning behind your suggestion that we make the template a required field instead, but I do think that we'll need to add some additional language making it clear that people can change the template/theme at a later date (in addition to adding further customizations within whatever template they choose). Somehow, we need to convey that the Commons has hundreds of themes and that they still have lots of flexibility if they want it.

I do think that the most basic version should just be called the "Default" template.

#3 Updated by Boone Gorges 9 months ago

Part of the confusion here may be the word "template". A "template", as I intend it here, is a "default configuration for a WP site". In this sense, we already have a single "template" on the Commons, and it doesn't make sense that you could opt out of one. There's probably a way to rename that kinda skirts the issue - "starter package" or something like that. A different name may also help to avoid the "theme" confusion.

In any case, the language and interface I've chosen is really just the first thing I thought of, and I'd be glad for someone else to step in with thoughts about how it might work better.

#4 Updated by Lisa Rhody 8 months ago

At the last commons meeting, I was asked to start working on language that could be used on the Layout Picker page. I'm afraid that enough time has elapsed that I'm not sure I remember exactly what we're striving for, but I've made some suggestions here:
https://docs.google.com/document/d/1JnQhKJF6LGz4EYwP32L98rjkGA4i-H9ZOGFSIq9L_QI/edit?usp=sharing

Best,
Lisa

#5 Updated by Boone Gorges 8 months ago

  • Related to Feature #7112: Add Copyright option/question to users on blog creation wizard added

#6 Updated by Boone Gorges 7 months ago

#7 Updated by Boone Gorges 7 months ago

  • Status changed from Reporter Feedback to In Progress

Implementation note (to self and Ray) that at least one template site must have a plugin package activated (Teaching -> Teaching). So, when setting everything up, the plugin package tools should be activated first, and then the Teaching package (etc) should be activated on the Teaching template site.

This means I'll need to build something into the cloning routine that copies over the relevant piece of blogmeta - this won't happen automatically.

#8 Updated by Boone Gorges 7 months ago

Ray, I've added some integration with cac-plugin-packages: https://github.com/cuny-academic-commons/cac-site-templates/commit/7be6fc8c8fc8da489d5b7cdbd190f378b1a6f421 The activated plugins themselves are copied as part of the options table, but I added extra stuff for the cac_site_templates option (it's not autoloaded, so it doesn't get moved over by default) and for the blogmeta stuff. I figured it made sense to update the "activated" date to the timestamp of cloning, since it's kinda silly to have "activated" dates that are prior to the creation of the site. Let me know if you think there's a better way to do this.

#9 Updated by Stephen Real 7 months ago

  • Subject changed from Site templates to Template posts showing up in activity feed

When I create a new site from a template, several posts that Paul wrote as part of creating the template, are showing up in the activity feed. At least that's what it looks like. I created a site called Red Rooster and almost immediately an activity record appeared for Paul's post saying it was written 8 days ago. Similar results with site Purple Moose.

#10 Updated by Stephen Real 7 months ago

  • Subject changed from Template posts showing up in activity feed to Cannot open my new site

As of 10:30 on Saturday morning, I cannot get to my recently created sites (Purple Moose and Red Rooster). The sites appear in the list of my sites, but when I click the link, my current page is re-rendered after a slight pause. The link address is https://purplemoose.commons.gc.cuny.edu/wpadmin/

Further info on this issue. Only Chrome is doing it. Works fine in Safari. Also the Site "Header" appears at the top of the screen, but the Commons "Home" page is the one that renders. See screenshot

#11 Updated by Boone Gorges 7 months ago

  • Subject changed from Cannot open my new site to Site templates

I'll take a look at these issues later, Steve, though at a glance, it sounds like the activity thing is a legit bug and the "can't access" is a local configuration issue. In either case, please don't change the name of this ticket to be too specific, as it's meant to be a general ticket for tracking changes on the development of site templates.

#12 Updated by Boone Gorges 7 months ago

I've confirmed the activity behavior and fixed it in https://github.com/cuny-academic-commons/cac-site-templates/commit/afcecd4394e94db4abcd549a72421808b12aff0b. Note that "Steve created a site" activity items are still generated, but the "new post" activity items are not.

Regarding your ability to access your recently created sites - I cannot reproduce. My guess is that you did not add the new domain names (eg purplemoose.commons.gc.cuny.edu) to the proper line in /etc/hosts. Could you confirm and try again?

#13 Updated by Stephen Real 7 months ago

Screenshot of Chrome Window After clicking the link to a site called Green Monster. Page re-renders identically when any of the site links are clicked.

#14 Updated by Stephen Real 7 months ago

Boone,
Your theory about the Hosts file is correct. I added one of the new sites to the Hosts file and Chrome started working. Odd that Safari did not need that entry to get to the site.

#15 Updated by Boone Gorges 7 months ago

  • Related to Bug #10595: Confirmation page after site creation has double footer added

#16 Updated by scott voth 7 months ago

Jetpack was the only plugin that was automatically activated when I tested the Academic portfolio. Not sure if an issue or not. Everything worked fine otherwise.

#17 Updated by Boone Gorges 7 months ago

Thanks, Scott! The behavior is expected - the academic portfolio template currently on cdev only has Jetpack activated. Presumably the final version will have more than that, but the spec is not yet finalized.

#18 Updated by Luke Waltzer 7 months ago

Just an update on where we are with this process; Boone, please let us know if you see any red flags.

Paul and I aim to finalize layout and settings on the Teaching Template and Academic Portfolio Template on the production server by Thursday. We'll then request that these templates be cloned to http://default-template-demo.commons.gc.cuny.edu and https://teaching-template-demo.commons.gc.cuny.edu so that we can plug in dummy content.

We have not touched the Default template, and were not planning to do so.

One new wrinkle that we've not discussed is that we've asked Ryan to design some custom headers to use with the Teaching Template... we realize that this may add a layer to the cloning process, so wanted to let Boone know that was coming.

#19 Updated by Boone Gorges 7 months ago

Luke, thanks very much for the update.

Your plan sounds good to me. To be clear, I assume you mean that each of 'teaching-template.', 'academic-portfolio-template', and 'default-template' will be cloned to the corresponding '-demo' versions.

I assume by "custom headers" you mean uploaded images that can then be selected at Dashboard > Appearance. If so, then no, it shouldn't pose a problem, though your comment did remind me that I'd forgotten to build a cloning routine for theme mods. I've resolved this in https://github.com/cuny-academic-commons/cac-site-templates/commit/36e3853cfd9a2f0c73b9d55983f812dcd63f12a7. It dawns on me that this is going to be a problem for CBOX-OL as well, so I've opened a ticket there to port the fix. https://github.com/cuny-academic-commons/commons-in-a-box/issues/156

Once the template sites are fully configured and the demo sites populated, I'll take screenshots of the demo sites to populate the template-picker during site creation. I think this will round out the feature set.

#20 Updated by Luke Waltzer 7 months ago

Your plan sounds good to me. To be clear, I assume you mean that each of 'teaching-template.', 'academic-portfolio-template', and 'default-template' will be cloned to the corresponding '-demo' versions.

I assume by "custom headers" you mean uploaded images that can then be selected at Dashboard > Appearance. 

Correct on both accounts. Will let you know when we're ready to clone!

#21 Updated by Luke Waltzer 6 months ago

Boone-- https://academic-portfolio-template.commons.gc.cuny.edu is ready for cloning to https://academic-portfolio-template-demo.commons.gc.cuny.edu.

Still need a bit of time on the Teaching template, but hopefully tomorrow.

Thx-

#22 Updated by Luke Waltzer 6 months ago

Ok, Teaching Template is done. Please clone https://teaching-template.commons.gc.cuny.edu/ to https://teaching-template-demo.commons.gc.cuny.edu/.

Note that after the release, we're going to have to go in an manually add the Campus Branding and One Search widgets to both the template and and demo site.

Thanks!

#23 Updated by Boone Gorges 6 months ago

Thanks, Luke.

I've cloned all content and settings in the following cases:
teaching-template -> teaching-template.demo
default-template -> default-template.demo
academic-portfolio-template -> academic-portfolio-template

Please set up the demo sites as you'd like them, and then provide me with screenshots.

Note with the Campus Branding and One Search widgets that the template sites shouldn't have a campus selected, as it's not possible at the moment for us to determine the proper campus at the time of template cloning. This is a future enhancement, once more of the course infrastructure is in place.

#24 Updated by Luke Waltzer 6 months ago

Boone: Scott is reporting that though he's an admin on https://academic-portfolio-template-demo.commons.gc.cuny.edu/ he's still getting a permissions error "You need a higher level of permission." when he tries to edit that site; can you please advise?

Thx-

#25 Updated by Boone Gorges 6 months ago

Luke/Scott - Can you please let me know what you mean by "edit"? Exactly what are you doing, and exactly what are you seeing? I've got to have URLs in order to debug.

#26 Updated by Boone Gorges 6 months ago

Quick follow-up - there may have been a cloning issue with roles not being copied properly - please give another quick try

#27 Updated by Luke Waltzer 6 months ago

Scott was able to access the site and make the changes. Demos are now populated with content, visibility set to "Discourage search engines from indexing this site."

I've attached screenshots for each of the three demo sites. Please let me know if there's any other outstanding tasks to prep the templates prior to release.

#28 Updated by Boone Gorges 6 months ago

Thanks, Luke - this is great.

The "Site Layout" section on cdev's https://commons.gc.cuny.edu/sites/create/ now reflects what the production version will look like after launch (with the exception of the "demo" links, which are absent on cdev because I haven't created demo sites there). I have attached two PDFs showing what this looks like - they wouldn't fit into a single PDF without scrolling.

After setting up the template metadata after tomorrow's release, my last todo is to activate the Teaching Package plugin package on the Teaching Template site, so that it'll be cloned to new sites using the teaching template.

Because this task is technically complete, I'm closing in advance of tomorrow's release.

#29 Updated by Boone Gorges 6 months ago

One more post-release todo for me that I forgot to mention: changing the privacy level of the demo sites, so that they can be viewed. I'll be changing them to "Discourage search engines...", which will keep them from search engines but will allow anyone to view them.

#30 Updated by Luke Waltzer 6 months ago

Boone-- did we discuss opening links to Demo sites via the Site Template picker in a new window? Might make sense in the site creation flow to do that.

#31 Updated by Boone Gorges 6 months ago

  • Related to Feature #10712: Open Site Template demo links in new window? added

#32 Updated by Boone Gorges 6 months ago

Luke - I've opened #10712 to discuss it.

Also available in: Atom PDF