Project

General

Profile

Support #14733

Academic Interests UI

Added by scott voth about 2 months ago. Updated about 1 month ago.

Status:
Duplicate
Priority name:
Normal
Assignee:
Category name:
Commons Profile
Target version:
-
Start date:
2021-08-27
Due date:
% Done:

0%

Estimated time:

Description

Ideally, the "Academic Interests" field on the Commons Profile page should be a hyperlink to others who share these interests. I don't see that it is serving this purpose.

I know that this is late in the game to propose a controlled vocabulary - should we even try for this?

As a workaround - can the interests be re-created as hyperlinks - I know they used to be, but the UI isn't very friendly to this sort of filter. Most profiles I look at do not have interests as hyperlinks.


Related issues

Related to CUNY Academic Commons - Feature #2753: Create actual actual tagification in academic interests and other fields New2013-08-26

History

#1 Updated by Boone Gorges about 2 months ago

  • Related to Feature #2753: Create actual actual tagification in academic interests and other fields added

#2 Updated by Boone Gorges about 2 months ago

  • Status changed from New to Duplicate

I don't know about a controlled vocabulary - how would our team be able to devise a vocabulary that would suffice? But a folksonomic solution, where people provide their own tags but are also offered the option of existing tags, could be good. This was discussed long, long ago in #2732. Related tickets are #5827, #3042. I'm going to mark this ticket as a dupe of #2732 and connect the tickets for more visibility.

#3 Updated by Colin McDonald about 2 months ago

Hi Scott, can you share any links to profiles you know about that have interests as hyperlinks? I don't think I've seen that before (maybe before my time...).

In addition the tickets Boone mentions, in ticket #8897 we talked a bit about keeping Academic Interests free entry but making sure you could mine them via the search, and also have them prioritized with other text like "English" that could show up elsewhere in a profile.

I'm not sure how we could go about the hyperlinking without a big overhaul on that ticket's work. One can always use the search, though it's necessarily more messy but could also surface your interest phrase in new ways.

#4 Updated by scott voth about 2 months ago

Hi Colin - We used to display them as hyperlinks - I didn't realize we'd officially turned them off and also how many tickets there are on this issue. I agree with Boone that a folksonomy is the way to go, with auto suggestions. It does seem like an important feature for the Commons.

#5 Updated by Raymond Hoh about 2 months ago

Hyperlinking appears to be the easiest option.

Sample hyperlink: https://commons.gc.cuny.edu/members/?filters%5Bkeyword%5D=digital+humanities

This does use the freeform keyword search on the Members Directory page, but it matches all profile fields, which could be a bonus? The problem is some members use different delimiters to separate their academic interests such as a comma or a semicolon. So if we decided to hyperlink, we should only hyperlink if a delimiter is used and if the field is not a paragraph.

#6 Updated by Sara Cannon about 1 month ago

After our discussion at the meeting, I think that a taxonomy across the site that allows users to mark events, sites, groups, users etc with an academic interest makes the most sense in the long term for usefulness and connectivity between users. Here is a UI example of a tagging interface that lets you select a pre-defined controlled vocabulary as well as giving you the option to create your own. We could have some warnings when a user creates their own about the usefulness of using one of the pre-defined taxonomies so they understand how it is used. If we wanted to close off the list even further, instead of "create" it could be "suggest" and could go to review for inclusion.

#7 Updated by Colin McDonald about 1 month ago

Thanks so much for this example and input, Sara! To get a bit more of the Friday meeting thoughts in here, we haven't quite resolved the debate yet on the utility and value of implementing a taxonomy like this.

I think we all agree it would be cool and could have a lot of future uses, but we'll want to flesh those out a bit more here before settling on a solution and devoting resources to it. We discussed how the structured data would allow us to surface or suggest specific items for users, like sites/groups/conferences/etc, based on shared interest terms between the user and the relevant item.

Boone mentioned that right now, a taxonomy for interests on the People page may just be a shortcut for searching those interests on your own -- linking the term wouldn't be that different from typing it in the search bar. So is this less about search and self-directed discovery of common connections, and more about formatting relationships so we can connect people through future features?

Luke wondered about the cost/benefit of this, whether this data-driven serendipity would ever really win out over people connecting on their own, at events, etc. Anthony thought that emphasizing and sorting these interests for Commons users would be helpful when he uses the Commons to teach about digital academic identity.

I also wasn't sure if we covered what we might do with current users and their academic interest fields that predate the new taxonomy -- prompt them to adjust to fit the structure?

#8 Updated by Matt Gold about 1 month ago

thank you for collecting this feedback, Colin!!

Also available in: Atom PDF