Project

General

Profile

Actions

Bug #19550

open

A few issues/questions around CV editor

Added by Matt Gold 3 months ago. Updated 6 days ago.

Status:
Assigned
Priority name:
Normal
Assignee:
Category name:
-
Target version:
-
Start date:
2024-01-18
Due date:
% Done:

0%

Estimated time:
Deployment actions:

Description

Hi All -- I just made some updates to my CV, which worked well! I have some questions, though:

1. I added a cover image and now want to remove it. However, I'm unable to get my cursor focus to be on the modal, so I can't scroll to see the options to remove the cover image. When I scroll, the background of the page moves, but I can't adjust the modal to the point where I can see any options. Screenshot attached and I can create a video if needed

2. after I updated my CV (I had one in the system previously), many content blocks were noted as problematic and I was asked to try to attempt recovery. Is this expected behavior? Screenshot attached.

Thank you!


Files

Screenshot 2024-01-18 at 12.16.34 PM.png (1.5 MB) Screenshot 2024-01-18 at 12.16.34 PM.png header image issue Matt Gold, 2024-01-18 12:18 PM
Screenshot 2024-01-18 at 12.09.09 PM.png (351 KB) Screenshot 2024-01-18 at 12.09.09 PM.png attempt block recovery issue Matt Gold, 2024-01-18 12:19 PM
bereniceabbott_documentingscience10 copy.jpg (54.5 KB) bereniceabbott_documentingscience10 copy.jpg Matt Gold, 2024-01-18 01:34 PM
Screenshot 2024-03-15 at 11.48.36 AM.png (118 KB) Screenshot 2024-03-15 at 11.48.36 AM.png Laurie Hurson, 2024-03-15 11:59 AM
CV editing adding list item issue.mp4 (2.08 MB) CV editing adding list item issue.mp4 Laurie Hurson, 2024-03-15 11:59 AM
Peek 2024-03-15 14-29.gif (83.1 KB) Peek 2024-03-15 14-29.gif Boone Gorges, 2024-03-15 03:29 PM
CV editor w console.mp4 (3.16 MB) CV editor w console.mp4 Laurie Hurson, 2024-03-21 09:44 AM
laurie-cv.json (8.7 KB) laurie-cv.json Boone Gorges, 2024-03-22 12:44 PM

Related issues

Related to CUNY Academic Commons - Bug #19531: CV: Cover Image - uploading xl image bugResolvedJeremy Felt2024-01-16

Actions
Actions #1

Updated by Matt Gold 3 months ago

BTW, here is the image I tried to add as a header. It's probably not the right dimensions (longer than it is wide), which may be why the problem occurred.

Actions #2

Updated by Boone Gorges 3 months ago

2. after I updated my CV (I had one in the system previously), many content blocks were noted as problematic and I was asked to try to attempt recovery. Is this expected behavior? Screenshot attached.

The ones related to Positions were due to a small change we made during development in the way that "campus" data is stored. The change was made in the cac-cv-editor plugin but not properly reflected in the migration script. I've just written and deployed a tool that is fixing it on all existing CVs.

The one related to your 'Education' row seems to be due to a bit of stray markup <!-- EndFragment --> that must have been in the original source content. It seems that this probably originated in some copy/paste behavior at the OS or browser level. https://github.com/w3c/clipboard-apis/issues/193 I don't have a clear idea of how to fix this across the board. When you click 'Attempt Block Recovery' it should just work, getting rid of the HTML comment.

I'll leave the cover image issues to Jeremy.

Actions #3

Updated by Raymond Hoh 3 months ago

  • Related to Bug #19531: CV: Cover Image - uploading xl image bug added
Actions #4

Updated by Raymond Hoh 3 months ago

The portrait cover image issue is tracked in #19531. Will take a quick look to see if we can implement a quick fix.

Actions #5

Updated by Matt Gold 3 months ago

Thank you!

Actions #6

Updated by Boone Gorges 3 months ago

  • Category name set to CV
  • Status changed from Assigned to Resolved
  • Target version set to Not tracked
Actions #7

Updated by Colin McDonald 3 months ago

  • Category name deleted (CV)
  • Status changed from Resolved to Assigned
  • Target version deleted (Not tracked)

I'm adding Zach and Laurie as watchers here. Zach mentioned on Friday during the call that he was still seeing some other "recovery" buttons come up on his migrated CV. He might have some screenshots to share, just in case they help illustrate these issues further, though I understand we might have done all we can on this and it will just require users to hit the "recovery" button and go from there.

Actions #8

Updated by Laurie Hurson about 1 month ago

Hi All,

Adding that I am still having some issues with CV editing and cannot recover blocks when they disappear. See screenshot and video

I am using the CV bottom block. When I try to add a new list item in a block, I put my cursor on the existing last line of the content and hit enter. When I do this, the CV line disappears and I get an error message. I cannot recover the lost content and the only way to resolve is to leave the CV editor before updating (content is not deleted if I leave)

Actions #9

Updated by Boone Gorges about 1 month ago

Laurie, I tried switching to your account and reproducing. But when inserting the cursor at the end of the line and pressing enter, I don't see the crash. See attached gif.

Could you try again, this time opening your browser console first? F12. Make sure you can see the 'Console' section where errors are shown. Then let me know what you see after attempting this edit.

Actions #10

Updated by Laurie Hurson 25 days ago

Hi All,

Ran this process again with console open, see video and text below. Let me know if this is not the correct way to do this.

Thanks!

GET
https://commons.gc.cuny.edu/members/laurieh/edit-cv/
[HTTP/1.1 404 Not Found 3108ms]

JQMIGRATE: Migrate is installed, version 3.4.1 jquery-migrate.min.js:2:981
Layout was forced before the page was fully loaded. If stylesheets are not yet loaded this may cause a flash of unstyled content. node.js:401:1
Uncaught ReferenceError: lodash is not defined
<anonymous> https://commons.gc.cuny.edu/wp-content/plugins/cac-site-templates//dist/block.build.js?ver=6.4.2-2.3.4:2
<anonymous> https://commons.gc.cuny.edu/wp-content/plugins/cac-site-templates//dist/block.build.js?ver=6.4.2-2.3.4:2
<anonymous> https://commons.gc.cuny.edu/wp-content/plugins/cac-site-templates//dist/block.build.js?ver=6.4.2-2.3.4:2
block.build.js:2:1636665
You are running Vue in development mode.
Make sure to turn on production mode when deploying for production.
See more tips at https://vuejs.org/guide/deployment.html build.js:17496:43
wp.blockEditor.useSetting is deprecated since version 6.5. Please use wp.blockEditor.useSettings instead. index.js:77:9
wp.blockEditor.__experimentalRecursionProvider is deprecated since version 6.5. Please use wp.blockEditor.RecursionProvider instead. index.js:77:9
wp.data.dispatch( 'core/editor' ).setupEditorState is deprecated since version 6.5. Please use wp.data.dispatch( 'core/editor' ).setEditedPost instead. index.js:77:9
Some cookies are misusing the recommended “SameSite“ attribute 5
MouseEvent.mozPressure is deprecated. Use PointerEvent.pressure instead. tinymce.min.js:2:8857
MouseEvent.mozInputSource is deprecated. Use PointerEvent.pointerType instead. tinymce.min.js:2:8857
TypeError: S is undefined
ww index.js:135
St react-dom.min.js:1
yr react-dom.min.js:1
$s react-dom.min.js:1
Sl react-dom.min.js:1
kl react-dom.min.js:1
bl react-dom.min.js:1
dl react-dom.min.js:1
react-dom.min.js:1:53535
TypeError: o is undefined
v_ block.js:665
St react-dom.min.js:1
yr react-dom.min.js:1
hr react-dom.min.js:1
$s react-dom.min.js:1
Sl react-dom.min.js:1
kl react-dom.min.js:1
bl react-dom.min.js:1

Actions #11

Updated by Boone Gorges 24 days ago

Thanks, Laurie. I was able to reproduce this by using Firefox, as in your video.

Jeremy, could you have a look? I've attached a JSON containing the contents of Laurie's CV. I could reproduce the problem locally, but when I ran `npm run start` the entire editor crashed, so I thought instead of digging deeper I would leave it to the experts :-D

Actions #12

Updated by Jeremy Felt 6 days ago

A eureka moment that should have come earlier and a fix for adding list items to existing lists is in the fix/update-isolated-block-editor branch.

Of note for any future spelunkers:
  • This only affected existing lists.
  • When "enter" was used to add a new list item, the block would throw an error and become unusable.
  • When the block selector was used to add a new list item, it would work fine.
  • If the block selector was used to add a new list item, it was possible to then use "enter" to add a new list item after that one, but not the others in the list.

This was somehow all related to the replacement of React 17's ReactDOM.render with React 18's ReactDOM.createRoot.

I'll have another branch soon that will update the isolated block editor further, but this will fix the immediate issue.

Actions

Also available in: Atom PDF